summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick White <git@njw.me.uk>2010-04-18 17:11:33 +0100
committerNick White <git@njw.me.uk>2010-04-18 17:11:33 +0100
commitde4d001f691e07f972fd512e3f1cc0b9bafab853 (patch)
tree4f556c0bbbaefe6bd6f8a00e121c28286dbd3749
parent5833df9fd700f7734b11035ef54c8e0f7165c0b3 (diff)
downloadnjw-gentoo-local-de4d001f691e07f972fd512e3f1cc0b9bafab853.tar.bz2
njw-gentoo-local-de4d001f691e07f972fd512e3f1cc0b9bafab853.zip
Add ebuild for digital (and copies of renpy dep)
-rw-r--r--dev-games/renpy-modules/renpy-modules-6.10.2.ebuild36
-rw-r--r--dev-games/renpy/files/renpy-jedit-path.patch11
-rw-r--r--dev-games/renpy/renpy-6.10.2-r1.ebuild80
-rw-r--r--games-rpg/digital/digital-1.1.ebuild27
4 files changed, 154 insertions, 0 deletions
diff --git a/dev-games/renpy-modules/renpy-modules-6.10.2.ebuild b/dev-games/renpy-modules/renpy-modules-6.10.2.ebuild
new file mode 100644
index 0000000..49c2d72
--- /dev/null
+++ b/dev-games/renpy-modules/renpy-modules-6.10.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+PYTHON_DEPEND="2:2.5"
+
+inherit distutils eutils
+
+MY_P=${PN%-modules}-${PV}
+PYTHON_MODNAME="pysdlsound"
+
+DESCRIPTION="Modules for renpy"
+HOMEPAGE="http://www.renpy.org"
+SRC_URI="http://www.renpy.org/dl/${PV}/${MY_P}-source.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="media-libs/libpng
+ media-libs/libsdl
+ media-libs/freetype:2
+ media-video/ffmpeg
+ dev-libs/fribidi
+ dev-python/pygame[X]
+ sys-libs/zlib
+ !=dev-games/renpy-6.10.2"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}/module"
+
+# RENPY_DEPS_INSTALL is a double-colon separated list of directories that
+# contains all core renpy dependencies. This is usually /usr.
+export RENPY_DEPS_INSTALL="${ROOT}usr"
diff --git a/dev-games/renpy/files/renpy-jedit-path.patch b/dev-games/renpy/files/renpy-jedit-path.patch
new file mode 100644
index 0000000..e45c885
--- /dev/null
+++ b/dev-games/renpy/files/renpy-jedit-path.patch
@@ -0,0 +1,11 @@
+--- a/launcher/jEdit.editor.py 2009-07-05 23:42:37.000000000 +0600
++++ b/launcher/jEdit.editor.py 2010-01-18 21:46:37.453619044 +0500
+@@ -6,7 +6,7 @@
+ import os.path
+ import sys
+
+-editor = os.path.normpath(base + "/../jedit/jedit.jar")
++editor = os.path.normpath("/usr/share/jedit/jedit.jar")
+ editor = renpy.shell_escape(editor)
+
+ if sys.platform == 'win32':
diff --git a/dev-games/renpy/renpy-6.10.2-r1.ebuild b/dev-games/renpy/renpy-6.10.2-r1.ebuild
new file mode 100644
index 0000000..be93910
--- /dev/null
+++ b/dev-games/renpy/renpy-6.10.2-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+PYTHON_DEPEND="2:2.5"
+
+inherit confutils eutils games python versionator
+
+DESCRIPTION="Visual novel engine written in python"
+HOMEPAGE="http://www.renpy.org"
+SRC_URI="http://www.renpy.org/dl/${PV}/${P}-source.tar.bz2"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~x86"
+IUSE="development doc examples"
+
+RDEPEND="dev-python/pygame[X]
+ >=dev-games/renpy-modules-${PV}"
+
+pkg_setup() {
+ confutils_use_depend_any examples development
+ games_pkg_setup
+}
+
+src_prepare() {
+ # Fix path to app-editors/jedit
+ epatch "${FILESDIR}"/${PN}-jedit-path.patch
+
+ find renpy -iname '*.pyo' -delete
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/${P}
+ exeinto "${GAMES_DATADIR}"/${P}
+
+ doexe renpy.py || die "doexe failed"
+
+ dodir "${GAMES_BINDIR}" || die "dodir failed"
+ P_SLOT=${PN}-${SLOT}
+ cat <<-EOF > "${D}"/"${GAMES_BINDIR}"/${P_SLOT} || die "Failed to create ${P_SLOT}"
+ #!/bin/sh
+ RENPY_BASE="${GAMES_DATADIR}"/${P} "${GAMES_DATADIR}"/${P}/renpy.py "\${@}"
+ EOF
+
+ doins -r common renpy || die "doins failed"
+
+ if use development; then
+ doins -r launcher template || die "doins failed"
+
+ newicon launcher/logo32.png ${P}.png || die "newicon failed"
+ make_desktop_entry ${P_SLOT} "Ren'Py ${PV}" ${P} Game "${GAMES_DATADIR}"/${P} || die "make_desktop_entry failed"
+ fi
+
+ if use examples; then
+ doins -r the_question || die "doins failed"
+ doins -r tutorial || die "doins failed"
+ fi
+
+ dodoc CHANGELOG.txt || die "dodoc failed"
+
+ if use doc; then
+ dohtml -r doc || die "dohtml failed"
+ fi
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ python_mod_optimize "${GAMES_DATADIR}/${P}"
+ if use development; then
+ elog "You need to emerge app-editors/jedit to easily use renpy development interface."
+ fi
+ games_pkg_postinst
+}
+
+pkg_postrm() {
+ python_mod_cleanup "${GAMES_DATADIR}/${P}"
+}
diff --git a/games-rpg/digital/digital-1.1.ebuild b/games-rpg/digital/digital-1.1.ebuild
new file mode 100644
index 0000000..d1f6355
--- /dev/null
+++ b/games-rpg/digital/digital-1.1.ebuild
@@ -0,0 +1,27 @@
+inherit games
+
+DESCRIPTION="Digital: A love story - A computer mystery/romance set five minutes into the future of 1988"
+HOMEPAGE="http://scoutshonour.com/digital/"
+SRC_URI="http://digital.artfulgamer.com/${P}.tar.bz2"
+
+LICENSE="CCPL-Attribution-ShareAlike-NonCommercial-3.0"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-games/renpy:6.10
+ media-video/ffmpeg"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cd Digital-linux-x86
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r game/* || die "doins failed"
+
+ games_make_wrapper ${PN} "renpy-6.10 \"${GAMES_DATADIR}/${PN}\""
+
+ dodoc README.html || die "dodoc failed"
+
+ prepgamesdirs
+}